Содержание

Руководство пользователя программы AutoTrade

Содержание

1. AutoTrade

Назначение программы AutoTrade

Принцип работы

Описание работы

Закладки

Кнопки на панели инструментов

Панель статусов

Установка программы AutoTrade

Настройки при использовании программы QUIK

Настройки при использовании программы SmartTrade

Настройки AutoTrade

Позиции

Терминалы

Сообщения

Инструменты

Фильтры

2. QUIK

Настройки ИС QUIK

Импорт транзакций

Загрузка дополнительных настроек

3. Omega Research

Установка Omega Research

Настройки Omega Research

Кондратенко Юрий © 2007-2010

Сайт: www.yurikon.net

Техническая поддержка: yurikon03@yandex.ru


AutoTrade

1. AutoTrade

Назначение программы AutoTrade

Принцип работы

Описание работы

Закладки

Кнопки на панели инструментов

Панель статусов

Установка программы AutoTrade

Настройки при использовании программы QUIK

Настройки при использовании программы SmartTrade

Настройки AutoTrade

Позиции

Терминалы

Сообщения

Инструменты

Фильтры


Назначение программы AutoTrade

Программа AutoTrade предназначена для автоматизации процесса торговли на фондовом рынке. В связке с программами Omega Research и Quik программа AutoTrade позволяет создать торгового робота, реализующего торговую стратегию, написанную на языке Easy Language.

Возможности программы AutoTrade

▪ исполняет сигналы любых работающих стратегий на языке Easy Language на любых разрешениях данных (дни, часы, минуты и т.д.);
▪ позволяет просматривать информацию из Tracking Center (Открытые позиции, Активные ордера, Исполненные ордера, Отмененные ордера) в русифицированном виде;
▪ имеется возможность автоматического и «ручного» режима работы; в ручном режиме трейдер сам решает, какие из ордеров выставить в ИС Quik либо отменить;
▪ просматривать таблицу Клиентский портфель и Котировки (при работающем выводе данных из ИС Quik);
▪ предусмотрен гибкий механизм задания размера позиции, а именно – согласно настройкам стратегии, фиксированная сумма или доля счета для всех инструментов, фиксированная сумма или доля счета по каждому инструменту;
▪ возможность вести торговлю на фондовой секции ММВБ, биржевом рынке РТС (РТС СГК) и ФОРТС;
▪ информировать пользователя по электронной почте, sms о следующих событиях: отправке транзакции, регистрации транзакции, обрыве/восстановлении соединения;
▪ программа ведет Журнал всех операций и событий, который доступен в самой программе и сохраняется в файле AutoTrade.log.

Программа может вставлять заявки как по одному счету, так и по группе счетов. Торговля по группе счетов очень удобна для управляющих, работающих сразу по нескольким счетам клиентов.

Подробности о программе можно почитать на сайте www.yurikon.net/autotrade


Принцип работы

Quik экспортирует котировки в Global Server, хранилище данных Omega Research. Omega Research анализирует поступающие данные согласно открытым стратегиям. Если происходит сделка, то AutoTrade формирует соответствующий приказ с заданным проскальзыванием и записывает его в файл *.TRI, откуда он и попадает в торговую систему Quik. Результат о выполнении транзакции записывается в файл *.TRO и анализируется программой AutoTrade. Информация о таких событиях, как разрыв соединения, отправки транзакции в Quik, выполнение транзакции, отправляется пользователю на электронную почту либо по sms.


Описание работы

Закладки

Кнопки на панели инструментов

Панель статусов

Внешний вид программы представляет собой главное меню, панель инструментов, закладки и панель статусов в нижней части программы.

На закладках доступна следующая информация:

Открытые позиции (Omega) – список открытых на текущий момент позиций в Omega Research

Открытые позиции (QUIK) – список открытых на текущий момент позиций в ИС Quik, то есть позиции, которые были открыты в режиме автоматической торговли. Если позиция была открыта частично либо не открыта совсем, то можно отредактировать соответствующие поля в таблице. Для удаления записи используйте сочетание клавиш CTRL+DEL. Чтобы зафиксировать изменения, необходимо сойти с записи наследующую запись, переместив курсор вниз.

Активные ордера – список активных ордеров (стоп и лимит ордера, рыночные и ордера и ордера по закрытию здесь не отображаются, так как они попадают сразу в Исполненные ордера)

Исполненные ордера – список ордеров, которые были исполненные в реальном режиме времени

Снятые ордера – список ордеров, которые были отменены

Котировки – дублирует Текущую таблицу параметров из ИС Quik

Отчет по транзакциям – информация о результатах отправленных транзакциях

Журнал – журнал программы, в который заносится информация обо всех событиях; информация также записывается в файл AutoTrade.log.

Кнопки на панели инструментов имеют следующие функции:

– включает автоматический режим торговли, новые ордера попадают в ИС Quik при прохождении всех фильтров (инструмент торгуется, сигнал из указанной стратеги и рабочей области, сейчас время торговой сессии. Данная кнопка доступна, если есть подключение к базам данных.

– отключает автоматический режим торговли.

– отправляет выбранный ордер в ИС Quik. Функция доступна, если выбрана закладка Активные ордера либо Исполненные ордера. Используется в «ручном режиме», кяогда исполнение ордеров отдается на усмотрение трейдера.

– снимает активную заявку в ИС Quik по ее номеру. Функция доступна, если выбрана закладка Активные ордера либо Исполненные ордера.

– открывает окно со списком клиентов, по которым ведется автоматическая торговля по группе счетов.

– открывает окно настроек программы.

– подключается к базам данных.

– выход из программы.

– открывает окно с информацией о программе.

Панель статусов в нижней части программы содержит следующую информацию:

Подключение к Omega – имеется ли подключение к базе Omega Research; если нет подключения, то работа программы не возможна.

Подключение к Quik – имеется ли подключение к базе QuikData; работа программы возможна даже при отсутствии подключения. Не будут доступны только функции формирования размера позиции по доле счета, просмотр Клиентского портфеля и котировок.

Связь с сервером Quik – имеется ли соединение с сервером. Если связи нет, то выставлять ордера невозможно.

Отправлено транзакций X/Y/Z – количество X отправленных транзакций в Quik, Y – обработанных транзакций и Z – количество зарегистрированных транзакций.

Здесь же при отправке транзакции мигает зеленый кружок, если ордер не прошел фильтры – то красный.


Установка программы AutoTrade и первоначальная настройка

Настройки при использовании программы QUIK

Настройки при использовании программы SmartTrade

После запуска дистрибутива на Ваш компьютер будет скопирована программа AutoTrade, но этого еще недостаточно для корректной работы программы. Также необходимо выполнить первоначальные настройки программы, которые делаются один раз.

Настройки при использовании программы QUIK

1. Указать в настройках AutoTrade | Настройки | Терминалы путь к папке с файлами транзакций (*.TRI и *.TRO) (по умолчанию это C:\AutoTrade\Trans) и к файлу info.log.

2. Указать в настройках AutoTrade | Настройки | Терминалы пути к базе данных Omega Research Alerts. База данных Omega Research Alerts находится в [Папка Omega Research]\MyWork\Alerts11.mdb (по умолчанию Папка Omega research – это c:\Program Files\Omega Research.

3. Если установка программы AutoTrade проводилась в специально указанную папку, то в настройках AutoTrade | Настройки | Терминалы | Путь к базе QuikData указать путь к базе QuikData.mdb.

4. Указать в настройках AutoTrade | Настройки | Терминалы номер счета на бирже ММВБ, FORTS, а также номер брокерского счета (код клиента в форме заявки). Эти данные можно узнать у своего брокера.

5. Настроить в ИС Quik импорт транзакций (Торговля-Импорт транзакций из файла).

6. Загрузить настройки AutoTrade.wnd, которые идут в комплекте с программой.
Внимание: предварительно необходимо убрать галочку «Закрывать все окна перед загрузкой файла настроек» в ИС Quik | Настройки | Основные | Файлы настроек ! В противном случае текущие настройки удалятся.

7. На закладке AutoTrade в квике включить вывод по ODBC из таблицы Клиентский портфель через правую клавишу мышки. Также нужно поставить галочку Чистить таблицу перед выводом. В AutoTrade обновить портфель ч помощью правой клавиши мыши.

8. В языковых настройках поставить разделитель целой и дробной части точку “.”.

Если используется режим MULTI, то надо задать список квиков, в которые будут отправляться приказы. Затем в каждом из этих квиков настроить импорт транзакций из файлом «имя квика.TRI» и т.д. В данной версии указывать путь к каждому квику не обязательно, данная опция будет использована в будущих версиях.

Настройки при использовании программы SmartTrade

1. Указать путь к папке, из которой будут загружаться транзакции (по умолчанию это C:\Program Files\SmartTrade\Orders).

2. Если используется режим MULTI в списке терминалов задать данный путь для каждого из терминалов как показано на рисунке снизу.

Разрешить в SmartTrade Внешние приказы и указать источник – текстовый файл.


Настройки AutoTrade

Позиции

Терминалы

Сообщения

Инструменты

Фильтры


Позиции

Настройки AutoTrade: Позиции

При выставлении заявки AutoTrade определяет количество лотов согласно следующим выбранным опциям:

Кол-во из Omega Research. В заявке будет указано то количество лотов, которое сформировала Omega Research. Указать данное количество можно в настройках стратегии Costs | Default Trade Amount. Fixed Unit – фиксированное число акций, Dollars per Transactions – здесь задается сумма сделки, количество определяется перед открытием позиции по цене открытия.

Фиксированная сумма. Размер позиции будет равен указанной сумме для любого инструмента.

Доля счета (%). Размер позиции будет равен доле счета, указанной в графе «Текущие средства» в таблице «Клиентский портфель» в программе Quik.

Сумма по бумаге. Размер позиции будет равен сумме указанной по этому инструменту на закладке Инструменты.

Доля счета по бумаге (%). Тоже самое, что опция Доля счета (%), только используется доля счета для каждого инструмента, указанного на закладке Инструменты.

Важно:

Для корректной работы в режимах, где рассчитывается доля счета, необходимо, чтобы работал вывод данных по ODBC по соответствующему брокерскому счету из программы Quik в базу QuikData. При выборе любого параметра, кроме Кол-во из Omega Research, возможно некорректное закрытие позиции.

Торговля по ОДНОМУ СЧЕТУ – сделки совершаются только по счету указанному в настройках на закладке Quik.

Торговля по ГРУППЕ СЧЕТОВ – сделки совершаются по группе счетов активных клиентов, указанных на форме Клиенты.

Начало сессии и конец сессии задают временной интервал, в течение которого выставляются заявки в автоматическом режиме.

Точное закрытие позиции – если опция включена, то программа при закрытии позиции использует то количество лотов, которым стратегия открылась ранее. Информация о размере открытых позиций хранится на закладке Открытые позиции (РОБОТ) и может быть отредактирована. Это полезно например в случаях, когда шорт не был открыт фактически из-за запрета биржи, а в системе стоит шорт. Значит надо просто поставить 0 в количестве лотов по этой позиции, чтобы система не купила двойной объем при входе в Лонг.

Выставлять ордера заранее (табл. Активные ордера). Если выбрана эта опция, то ордера выставляются сразу, как только они появятся в таблице Активных ордеров. При генерации новых ордеров неисполненные ордера отменяются по номеру выставленной заявки. Если выбрана опция Выставлять рыночные ордера (табл. Исполненные ордера), то заявка попадет в Quik только по факту исполнения сделке – появления записи в таблице Исполненные ордера. Цена в заявке будет увеличена/уменьшена на величину Проскальзывания, указанного на закладке Инструменты.

QUIK, SmartTrade – указать тип терминала, через который идет торговля.


Терминалы

Настройки AutoTrade: Терминалы

На этой закладке указываются настройки, относящиеся к работе программы Quik и баз данных.

Путь к файлу транзакций – папка, в которой будут создаваться файлы с транзакциями.

Путь к файлу info.log – файл в папке программы Quik, по которому определяется наличие связи ИС Quik и сервера.

Путь к файлам для SmartTrade – папка, в которой будут создаваться файлы с транзакциями для терминала SmartTrade.

Номер счета на ММВБ – номер счета брокера на бирже ММВБ.

Номер счета на FORTS – номер счета на бирже FORTS.

Код/портфель клиента – номер брокерского счета клиента.

Интервал обновления данных – интервал времени в секундах, через который обновляются данные по ордерам и Клиентский портфель.

Интервал просмотра ордеров – интервал времени в секундах, через который программа проверяет наличие новых ордеров в таблицах Активных, Исполненных и Отмененных ордеров для обработки.

Проверять связь Quik`а с сервером через (сек.) – включает проверку связи Quik`а с сервером через указанное время в секундах.

База данных Omega Research Alerts – путь к базе данных, в которой хранится информация об ордерах.

База данных QuikData – путь к базе данных, в которой хранятся данные из ИС Quik и данные по инструментам.

Подключаться при запуске – если эта опция выбрана, то подключение к базам данных будет происходить автоматически при запуске программы.

Список терминалов для режима MULTI – список терминалов при торговле сразу в нескольких квиках.


Сообщения

Настройки AutoTrade: Сообщения

На этой закладке находятся настройки, связанные с отправкой сообщений пользователю.

Сервер исходящей почты – укажите здесь сервер, который используется для отправки почты. Например, smtp.yandex.ru.

Порт – порт сервера, обычно 25.

Пользователь – имя пользователя.

Пароль – пароль доступа, если требуется.

Требуется аутентификация – если сервер требует аутентификацию, поставьте здесь галочку.

Коннект/дисконнект – тестирование соединения.

Имя – имя отправителя.

E-mail адрес – электронный адрес отправителя, должен соответствовать серверу исходящей почты.

Адреса получателя E-mail 1 и E-mail 2 – два адреса, куда будут отправляться сообщения. Для отправки сообщений на сотовый телефон, необходимо узнать его электронный адрес. Например, +79123456789@sms.etk.ru.

Сообщение – тестовое сообщение для проверки почты.

События для отправки. Здесь необходимо выбрать события, о которых будет информирован пользователь.

Отправка транзакции – происходит, когда транзакция отправляется в ИС Quik.

Регистрация транзакции на сервере – происходит, когда заявка регистрируется на сервере ИС Quik.

Обрыв/восстановление соединения Quik`а с сервером – если связь с сервером пропадает более чем на указанное на закладке Quik время, то пользователь получает сообщение об этом. Также отправляется сообщение и при восстановлении связи.


Инструменты

Настройки AutoTrade: Инструменты

На этой закладке необходимо указать все инструменты, по которым будет вестись автоматическая торговля. Сигналы из Omega Research по инструментам, не указанным здесь, будут игнорироваться программой. По каждому инструменту заполняется следующая информация:

Тикер в Омеге – тиккер инструмента в Omega Research, может отличаться от кода в ИС Quik.

Торгуется – уберите флажок, если не хотите в данное время автоматически исполнять приказы по этому инструменту.

Сумма – торгуемая сумма по бумаге; используется, если выбрана опция Позиции | Сумма по бумаге. Для фьючерсов нужно указывать сумму в пунктах.

Доля счета (%) – доля счета в процентах, задействованная в торговле по этому инструменту.

Проскальзывание (%) – величина проскальзывания, на которую будет увеличена/уменьшена цена ордера на покупку/продажу. Также эта величина используется при выставлении стоп-заявок в качестве спреда между ценой условием и ценой исполнения.

Лот – размер лота в штуках.

Код класса – код класса инструмента, можно посмотреть в ИС Quik.

Знаки после запятой – количество знаков после запятой, для фьючерсов на акции укажите 0, для фьючерсов на индекс РТС укажите -1. Отрицательное значение указывает программе сколько последних разрядов округлить, так как в торговой системе могут быть ограничения на минимальный шаг цены. Для фьючерса на индекс РТС минимальный шаг составляет 5 пунктов. В AutoTrade этот разряд просто зануляется.

Код в Quik`е – код инструмента в ИС Quik.

Стоимость пункта – для акций стоимость пункта равна 1. Фьючерсов нужно задать стоимость пункта, чтобы

AutoTrade мог корректно рассчитывать размер позиций.


Фильтры

Настройки AutoTrade: Фильтры

Для предотвращения случайного исполнения нежелательных сигналов в программе предусмотрена система фильтров. Сигнал будет исполнен, если он удовлетворяет всем фильтрам одновременно (логическое И).

Просматриваемые рабочие области (*.orw) – имя рабочих областей (workspace) с расширением *.orw, откуда будут загружаться ордера.

Просматриваемые стратегии – перечень стратегий, которых будут приниматься сигналы.


2. QUIK

Настройки ИС QUIK

Импорт транзакций

Загрузка дополнительных настроек


Настройки ИС QUIK

Импорт транзакций

Загрузка дополнительных настроек

Импорт транзакций

Для динамической загрузки заявок в ИС Quik надо сделать следующие настройки. В главном меню Торговля | Импорт транзакций из файла нужно прописать пути к тем же файлам TRI и TRO, что указаны в настройках AutoTrade, а также указать путь к файлу TRR.

Интервал просмотра новых заявок рекомендуется установить равным 1 секунде.

Ниже перечисленные настройки необходимы только в том случае, если в программе AutoTrade будет использовано формирование ордеров по «Доле счета», в других случаях их можно не делать.

Загрузка дополнительных настроек

Для корректного формирования ордеров при использовании «доли счета», необходимо экспортировать по ODBC данные из Клиентского портфеля. Для этого нужно загрузить дополнительные настройки AutoTrade.wnd следующим образом. Во-первых, в меню Настройки | Основные | Файлы настроек убрать галочку напротив «Закрывать все окна перед загрузкой файла настроек». Если не убрать данную галочку, то все настройки заменятся на AutoTrade.wnd, что не желательно. Во-вторых, через Настройки | Загрузить настройки из файла выбрать файл AutoTrade.wnd, который идет в комплекте с программой AutoTrade. После этого в ИС Quik появится новая закладка AutoTrade с двумя таблицами Текущие параметры и Клиентский портфель. Выделив поочередно каждую из таблиц, надо в главном меню Экспорт данных | Вывести по ODBC включить вывод данных в предварительно созданный источник данных QuikData. Также можно поставить галочку напротив Начинать вывод по нажатию клавиш Ctrl+Shift+O и в будущем начинать вывод сразу по двум таблицам по нажатию этой комбинации клавиш.


3. Omega Research

Установка Omega Research

Настройки Omega Research


Установка Omega Research

В виду того, что корректная работа AutoTrade напрямую зависит от корректной работы Omega Research, ниже опишем существенные настройки последней.

Для того чтобы котировки выводились в режиме он-лайн, во время установки Omega Research необходимо указать следующие настройки:

1. В диалоге "3rd Party Data Vendor Software" установить опцию "DBC - Supports: Signal Broadcast, eSignal Online, and InSite Online."

2. В диалоге "DBC Data Feed Selection" установить опцию "eSignal Online".

3. Во время первого запуска программы Omega Research ProSuite она попросит вас настроить Global Server. Выберите опцию "Launch the GlobalServer Setup Wizard".

4. В диалоге "GlobalServer Setup Wizard - Data Collection Method" установите опцию "Real-Time/Delayed (You will be collecting...").

5. В диалоге "GlobalServer Setup Wizard - Select Datafeed" выберите опцию "DBC Online SubServer".

6. В диалоге "GlobalServer Setup Wizard - HISTORYBANK.COM ..." выберите опцию "No".

7. Во время первого запуска программы Global Server в диалоге выбора режима работы выберите режим "Start Online".

Также можете обратиться за готовым архивом котировок на CD-ROM и сэкономить на интернет трафике, написав запрос по электронной почте по адресу yurikon03@yandex.ru


Настройки Omega Research

Чтобы отрисовка графиков проходила нормально, надо сделать следующее:

1. Установить на компьютере часовой пояс (!) и время биржи (Москва), чтобы проще было определять другие параметры.

2. В настройках символа установить время сессий.

3. Установить время торговой сессии, торговые дни недели (все 7 дней недели выделять нельзя, иначе не будут отображаться недельные графики) в Global Server | Tools | Edit Exchange List | Выбранная биржа.

Также указать смещение часового пояса выбранной биржи от Гринвича в Edit DayLight Savings, для Москвы это 180 минут.

По умолчанию Omega Research помечает полученные данные текущим временем компьютера. Это весьма не удобно, если вывод данных из ИС Quik включается после начала торгов. Чтобы исправить этот недостаток можно воспользоваться «недокументированной возможностью» Omega Research. Для это в системный реестр нужно добавить следующий ключ:

[HKEY_CURRENT_USER\Software\Omega Research\Server\DBC Online SubServer.DBC Online]

«USEPCCLOCK»="NO"

Далее, чтобы Omega Research не только получала эталонные данные с биржи, но и корректно отрисовывала графики, следует использовать следующую схему запуска программ:

1. Запуск ИС Quik.
2. Перевести системное время на 4 часа назад.
3. Запуск в режиме офф-лайн Omega Research.
4. Открыть необходимые рабочие области (work space).
5. Перевести в режим он-лайн Global Server.
6. Вернуть системное время обратно.
7. Включить экспорт данных в систему технического анализа.
8. Запустить AutoTrade. Включить автоматический режим.
9. В ИС Quik включить импорт транзакций из файла.

После этого система готова к торговле.